<!DOCTYPE html><html lang="en"><head><script crossorigin="anonymous" src="https://polyfill.io/v3/polyfill.min.js?features=NodeList.prototype.forEach%2CArray.prototype.forEach%2CSymbol.hasInstance%2Ces6%2CIntl%2ClocalStorage%2CDate.prototype.toISOString%2CDate.now%2Cdefault%2CObject.entries%2CArray.prototype.entries"></script><title>Dave Turley’s Wednesday WX Forecast 6-23-3021</title><meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"/><meta http-equiv="X-UA-Compatible" content="IE=edge"/><meta charSet="UTF-8"/><meta name="distribution" content="global"/><meta name="rating" content="general"/><meta name="copyright" content="Copyright (c) 2021 "/><meta property="og:locale" content="en_US"/><meta property="og:type" content="article"/><meta name="apple-itunes-app" content="app-id=449970380"/><meta name="google-play-app" content="app-id=com.raycom.wtoc"/><meta name="burst" content="wtoc"/><meta property="og:url" content="https://www.wtoc.com/2021/06/23/dave-turleys-wednesday-wx-forecast-6-23-3021/"/><meta name="robots" content="index,follow,noarchive"/><meta name="googlebot" content="index"/><meta name="googlebot-news" content="index"/><meta itemProp="description" name="description" content="Dave Turley First Alert WX"/><meta property="og:description" content="Dave Turley First Alert WX"/><meta name="twitter:description" content="Dave Turley First Alert WX"/><meta property="fb:admins" content="644426401"/><meta property="fb:app_id" content="252156288151522"/><meta property="fb:pages" content="57237502362"/><meta property="article:publisher" content="https://www.facebook.com/wtoc11/"/><meta name="keywords" content="Dave Turley First Alert WX"/><meta name="news_keywords" content="Dave Turley First Alert WX"/><meta itemProp="image" property="og:image" content="https://gray-wtoc-prod.cdn.arcpublishing.com/resizer/q2FoK68tEy-atAQ26_U8Oe1QjWI=/980x0/smart/filters:format(jpg):quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/KZQOD2BCBNCYDOGZEHFFNFI56Y.png"/><meta name="twitter:image" content="https://gray-wtoc-prod.cdn.arcpublishing.com/resizer/q2FoK68tEy-atAQ26_U8Oe1QjWI=/980x0/smart/filters:format(jpg):quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/KZQOD2BCBNCYDOGZEHFFNFI56Y.png"/><meta property="og:site_name" content="https://www.wtoc.com"/><meta property="og:title" content="Dave Turley’s Wednesday WX Forecast 6-23-3021"/><meta name="twitter:title" content="Dave Turley’s Wednesday WX Forecast 6-23-3021"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@WTOC11"/><meta name="twitter:creator" content="@WTOC11"/><script type="application/ld+json" data-schema="NewsMediaOrganization">{
  "name": "WTOC",
  "url": "https://www.wtoc.com",
  "logo": {
    "@type": "ImageObject",
    "url": "https://www.wtoc.com/pf/resources/images/logo-off-site/wtoc.png?d=172"
  },
  "@type": "NewsMediaOrganization",
  "sameAs": [
    "https://www.facebook.com/wtoc11/",
    "https://www.twitter.com/WTOC11/"
  ],
  "@context": "http://schema.org"
}</script><script type="application/ld+json" data-schema="NewsArticle">{
  "name": "Dave Turley’s Wednesday WX Forecast 6-23-3021",
  "url": "https://www.wtoc.com/2021/06/23/dave-turleys-wednesday-wx-forecast-6-23-3021/",
  "image": "https://gray-wtoc-prod.cdn.arcpublishing.com/resizer/q2FoK68tEy-atAQ26_U8Oe1QjWI=/980x0/smart/filters:format(jpg):quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/KZQOD2BCBNCYDOGZEHFFNFI56Y.png",
  "@type": "NewsArticle",
  "@context": "http://schema.org",
  "description": "Dave Turley First Alert WX",
  "keywords": [
    "Dave Turley First Alert WX"
  ],
  "headline": "Dave Turley’s Wednesday WX Forecast 6-23-3021",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.wtoc.com/2021/06/23/dave-turleys-wednesday-wx-forecast-6-23-3021/"
  },
  "author": {
    "@type": "Person",
    "name": "Dave Turley"
  },
  "publisher": {
    "name": "WTOC",
    "url": "https://www.wtoc.com",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.wtoc.com/pf/resources/images/logo-off-site/wtoc.png?d=172"
    },
    "@type": "NewsMediaOrganization"
  },
  "datePublished": "2021-06-23T15:00:14.159Z",
  "datemodified": "2021-06-23T15:00:14.159Z"
}</script><script type="application/javascript" id="polyfill-script">if(!Array.prototype.includes||!(window.Object && window.Object.assign)||!window.Promise||!window.Symbol||!window.fetch){document.write('<script type="application/javascript" src="/pf/dist/engine/polyfill.js?d=172" defer=""><\/script>')}</script><script id="fusion-engine-react-script" type="application/javascript" src="/pf/dist/engine/react.js?d=172" defer=""></script><script id="fusion-engine-combinations-script" type="application/javascript" src="/pf/dist/components/combinations/default.js?d=172" defer=""></script><link id="fusion-template-styles" rel="stylesheet" type="text/css"/><link rel="stylesheet" href="https://gray-wtoc-prod.cdn.arcpublishing.com/pf/resources/dist/__global/css/main.css?d=172"/><link rel="stylesheet" href="https://gray-wtoc-prod.cdn.arcpublishing.com/pf/resources/dist/wtoc/css/main.css?d=172"/><link href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/5.10.2/css/all.min.css?d=172" rel="stylesheet"/><link rel="icon" type="image/x-icon" href="/pf/resources/images/favicons/wtoc/favicon.ico?d=172"/><script type="text/javascript" src="https://gray-wtoc-prod.cdn.arcpublishing.com/pf/resources/js/analytics/gtm.js?d=172"></script><script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://reconditerespect.com/v2skjj_Br8b7Mccmyt8vrRWEns2wZWMno6phmQ7ecd4_fSnXPbJPOBQgOCA",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(c,e,o,t,n){function r(o,t){(function n(){try{return 0<(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]}catch(o){}return!1})()&&(t=c[e].pubads())&&t.setTargeting("admiral-engaged","true")}(n=c[e]=c[e]||{}).cmd=n.cmd||[],typeof n.pubads===o?r():typeof n.cmd.unshift===o?n.cmd.unshift(r):n.cmd.push(r)})(window,"googletag","function");;;;!(function(t,n,i,u,e,o){var a=n[i];function r(t){if(t){var u=(t.data||{})[i+"Call"];u&&n[i](u.command,u.version,function(n,i){t.source.postMessage({__uspapiReturn:{returnValue:n,success:i,callId:u.callId}},"*")})}}if((function c(){if(!window.frames[u]){var n=t.body;if(n){var i=t.createElement("iframe");i.style.display="none",i.name=u,n.appendChild(i)}else setTimeout(c,5)}})(),"function"!=typeof a){var s={getUSPData:function(n,i){return n!==1?i&&i(null,!1):i&&i({version:null,uspString:null},!1)}};a=n[i]=function(n,i,t){return s[n](i,t)},n.addEventListener?n.addEventListener("message",r,!1):n.attachEvent&&n.attachEvent("onmessage",r)}o=t.createElement(e),t=t.getElementsByTagName(e)[0],o.src="https://reconditerespect.com/v2uheuNlQtZN3zRSEe0om4bZps9nK7URuxx99brFsdrq85GnUknJvRJzwBkTWcmkx1D0tzZW1v9w",t.parentNode.insertBefore(o,t)})(document,window,"__uspapi","__uspapiLocator","script");</script><script type="text/javascript" src="https://gray-wtoc-prod.cdn.arcpublishing.com/pf/resources/js/ads/arcads.js?d=172"></script><script type="text/javascript">
    var RCdataLayer = [
      {
        adTarget: "/weather/forecast",
        authors: [ {
            _id:  "dave-turley",
            name:  "Dave Turley",
            type:  "author"
          }],
        canonicalUrl: "https://www.wtoc.com/2021/06/23/dave-turleys-wednesday-wx-forecast-6-23-3021/",
        contentId: "T5VHY5X7FNE23HDIWGPTTOVU7A",
        contentKewords: [ "Dave Turley First Alert WX"],
        contentName: "Dave Turley\'s Wednesday WX Forecast 6-23-3021",
        contentOwner: "wtoc",
        contentTags: [ ],
        contentType: "story",
        datePublished: "06/23/2021",
        distributorCategory: "staff",
        distributorMode: "reference_denormalized",
        distributorName: "Gray TV Stations",
        distributorReferenceId: "6c4d5d7a-69c6-483e-8ffd-871ff31dbadb",
        distributorSubCategory: "gray-original-content",
        hasVideo: false,
        metaDescription: "Dave Turley First Alert WX",
        outputType: "default",
        platformName: "PageBuilder Fusion - Arc Publishing",
        primarySection: {
          _id:  "/weather/forecast",
          name:  "Forecast",
          path:  "/weather/forecast"
        },
        publishedDay: "23",
        publishedMonth: "06",
        publishedYear: "2021",
        stationName: "wtoc",
        subtype: "default",
        timezoneOffset: gdmGoogleTagManager.getTimezoneOffset(),
        userId: null,
        userTimezoneTimestamp: new Date(),
        userTimezone: Intl.DateTimeFormat().resolvedOptions().timeZone,
        userAgent: navigator.userAgent
      }
    ];
  </script><script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','RCdataLayer','GTM-M5QQ3JP');</script><script type="text/javascript" async="" src="https://widgets.outbrain.com/outbrain.js"></script><script id="a1c1c57f95064f50bba9396a0b142ced">!function(n){if(!window.cnxps){window.cnxps={},window.cnxps.cmd=[];var t=n.createElement('iframe');t.display='none',t.onload=function(){var n=t.contentWindow.document,c=n.createElement('script');c.src='//cd.connatix.com/connatix.playspace.js',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);</script>
  <script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"true","rua.upre":"false","rua.cpre":"true","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"SJ-31f84c3b-56ca-4866-9f89-e23293b4d849","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false","rua.isuxp":"false","rua.texp":"norulematch"}]);</script>
                          <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="5V893-MPCGC-LDXVY-RMZ24-H83UG",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,_,o,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",o=document.getElementsByTagName("script")[0],o.parentNode.insertBefore(r,o);try{_=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",_=r.contentWindow.document}_.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"5V893-MPCGC-LDXVY-RMZ24-H83UG",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},_.write("<bo"+'dy onload="document._l();">'),_.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e="true"=="true"?1:0,t="",n="nml5ubaxbsjsoygtk7kq-f-c7fd4d5ab-clientnsv4-s.akamaihd.net",i={"ak.v":"31","ak.cp":"1137770","ak.ai":parseInt("677332",10),"ak.ol":"0","ak.cr":1,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"d3d0202","ak.r":40759,"ak.a2":e,"ak.m":"a","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":42336,"ak.gh":"104.78.78.103","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1624463317","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==3Ya5MGwQqGzyxIMsKxNA39hvzfOoCcdG9wgeanDnBhff9i+jrttbbw8bjf8WbH5P3CqLrTyIXQARODNYdERz84PRHehKcqR6b07iJdxQipxNj5DxSUmmHIjid7DgEnKD516JVb8s9W6UgYotcfRVhOmLLdJTyHs2cXwWTR9kqi5Ic6zZa9cOJYl+ypZGralCExmxb/Ti9h2RXHiFJNjXhclG51WsZNTr7URnmZtQUEiRl+bnZhUHpXEs6uERmEA7Yfgb7iUJ6QMielzh/8676W7REVlx7JxY6tZOaP9/jMJ0W1V49+7GwSqmMRSNDX8HiF5PO90Bh6/PZtSPplZ7u/+kZgFsQhWNV8iSdmnZcg2FSyzOg/4tU8EJaccwc/YCTbGJXJXxANHrJxeNxlz8P9x8l7jPbT5/Z3ZF0tyJXnc=","ak.pv":"6","ak.dpoabenc":""};if(""!==t)i["ak.ruds"]=t;var _={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))i["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(i)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:i,akDNSPreFetchDomain:n,init:function(){if(!_.i){var a=BOOMR.subscribe;a("before_beacon",_.av,null,null),a("onbeacon",_.rv,null,null),_.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head><body><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fusion-app" class="fusion-app"><div id="article-right-rail-layout" class="includes-right-rail"><a class="skip-link sr-only sr-only-focusable px-3" href="#main">Skip to content</a><header id="main" class="masthead | w-100"><div class="sales-navigation | d-none w-100 bg-primary-branding d-lg-flex"><div class="container-xl"><div class="sales-nav-links | d-flex justify-content-start py-1"><div class="sales-nav-link |"><a class="text-nowrap text-reset text-decoration-none" href="/weather/cams">Sky Cams</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="/business/partners">Business Partners</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="/page/sponsorship-inquiries">WTOC Sponsorship Inquiry</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="/news/education/top-teacher">Top Teacher</a></div></div></div></div><div class="masthead | bg-primary-branding py-2" style="background-image:url(&#x27;/pf/resources/images/mastheads/backgrounds/wtoc.jpg?d=172&#x27;)"><div class="container-xl"><div class="d-flex justify-content-between w-100"><div class="logo flex-fill position-relative"><a class="logo-link" aria-label="Return to the Homepage" href="/"><div class="logo-inner position-absolute" style="background-image:url(&#x27;/pf/resources/images/mastheads/logos/wtoc.svg?d=172&#x27;)"></div></a></div></div></div></div></header><nav class="navigation | w-100"><div class="navigation | navigation-sticky-wrapper" style="min-height:undefinedpx"><div class="navbar | navbar-expand bg-primary-branding"><div class="container-xl position-relative"><a class="navbar-brand mr-1 d-none" aria-label="Return to the Homepage" href="/"><div class="brand-logo" style="background-image:url(&quot;/pf/resources/images/logo-icons/wtoc.svg?d=172&quot;)"></div></a><button aria-label="Expand Side Navigation Panel" class="side-drawer-toggle btn text-white" type="button"><span class="fas fa-bars"></span></button><ul class="navbar-links | navbar-nav mr-auto font-weight-bold"><li class="navbar-link | navbar-item d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/livestream">Live</a></li><li class="navbar-link | navbar-item d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/news">News</a></li><li class="navbar-link | navbar-item d-none d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/health/tracking-the-vaccine">Tracking the Vaccine</a></li><li class="navbar-link | navbar-item d-none d-md-flex d-lg-flex"><a class="nav-link text-white" href="/weather">Weather</a></li><li class="navbar-link | navbar-item d-none d-md-flex d-lg-flex"><a class="nav-link text-white" href="/news/investigate">Investigates</a></li><li class="navbar-link | navbar-item d-none d-lg-flex"><a class="nav-link text-white" href="/community">Community</a></li></ul><form class="search-box bg-primary-branding d-flex flex-row rounded position-absolute zindex-high w-auto p-1" action="/search/" method="GET"><input type="text" class="form-control form-control-sm bg-primary-branding m-0 p-0 border-0" aria-label="Enter search term" id="expandable-search" name="searchTerm" placeholder="Search..."/><button class="btn border-0 text-white" aria-label="Toggle search bar" type="button"><i class="d-block fas fa-search"></i></button><button class="btn btn-sm text-white border border-secondary sr-only" aria-label="Toggle search bar" type="submit">Search</button></form></div></div></div><div class="side-drawer-screen | fixed-top h-100 w-100 zindex-high"></div><div class="side-drawer | bg-primary-branding shadow-lg fixed-top h-100 w-100 overflow-y overflow-hide-scrollbar"><div class="side-drawer-container | d-none flex-column align-items-end h-100"><div class="side-drawer-cancel | w-100 p-2"><div class="d-flex flex-column align-items-end"><button aria-label="Close" class="btn btn-sm text-white"><i class="fas fa-times"></i></button></div></div><ul class="sections-list | list-unstyled w-100 pt-5 pb-4"><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/homepage">Home</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/programming/schedule">Programming Schedule</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/apps">Download Our Apps</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/community/user-content/">Submit Photos &amp; Videos</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/news">News</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/health/coronavirus">Coronavirus</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/health/tracking-the-vaccine">Tracking the Vaccine</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/crime">Crime</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/lowcountry">Lowcountry News</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/investigate">WTOC Investigates</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/education">Education</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/politics/elections">Elections Center</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/traffic">Traffic</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/national">National</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="http://www.circleallaccess.com/">Circle Country Music &amp; Lifestyle</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://www.fullcourtgreta.com/">Full Court Press with Greta Van Susteren</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://www.graydc.com/">Gray DC Bureau</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://www.investigatetv.com/">Investigate TV</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/weather">First Alert Weather</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/headlines">Headlines</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/cams">Sky Cams</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/hurricane">Hurricane Center</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="http://www.wtoc.com/story/38936600/astronomical-tide-river-data">Astronomical Tide And River Data</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/summer-weather-tips/">Summer Weather Tips</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="http://www.wtoc.com/video/2019/03/08/what-is-first-alert-weather-day/">What Is A First Alert Weather Day?</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/sports">Sports</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/endzone">End Zone</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/ncaa/georgia-southern">Eagle Report</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/golf">Golf</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/community">Community</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/outdoor-overhaul/">Outdoor Overhaul</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/community/good-news">Good News</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/community/champions">Community Champions</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/takingcareofbusiness">Taking Care of Business</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/community/holidays">Holidays HQ</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/morningbreak/food">Food</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/pet-pics">Pet Pics</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/community/calendar">Calendar</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/morningbreak">Morning Break</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/morningbreak/legal">Legal</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/morningbreak/music">Music</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/morningbreak/health">Health</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/morningbreak/diy">DIY</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/morningbreak/vacation">Vacation</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/morningbreak/style">Style</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/morningbreak/food">Food</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/morningbreak/outdoor">Outdoor</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/morningbreak/art">Art</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/podcasts">Podcasts</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/2020/07/29/wtoc-news-podcast/">WTOC News Podcast</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/2019/10/10/first-alert-weather-podcast/">First Alert Weather Podcast</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/2020/01/23/wtoc-sports-podcast/">WTOC Sports Podcast</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/about-us">About Us</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/about-us/contact-us">Contact Us</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/apps">Download Our Apps</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/about-us/meet-the-team">Meet The Team</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/2018/12/27/internships-wtoc">Internships</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/story/36467588/tune-us-in-antenna-tips-reception-troubleshooting">Antenna Tips</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/contests">Contests</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.vuit.com/live/15990/wtoc/vod#2:19236832">Latest Newscasts</a></div></li></ul><div class="social-bar | d-flex flex-row justify-content-center w-100 mt-auto p-3" style="bottom:0"><a aria-label="Visit WTOC on FACEBOOK" class="p-2" href="https://www.facebook.com/wtoc11" rel="noopener noreferrer" target="_blank"><i class="fab fa-facebook-f fa-2x"></i></a><a aria-label="Visit WTOC on TWITTER" class="p-2" href="https://www.twitter.com/WTOC11" rel="noopener noreferrer" target="_blank"><i class="fab fa-twitter fa-2x"></i></a></div></div></div><div class="breaking-news-bar |"></div></nav><section class="leaderboard | w-100"><div class="arc-ad | text-center ad-flex-leaderboard py-2 d-flex flex-column mt-3 mb-3 justify-content-center ad-type-flex-leaderboard"><div class="arc-ad-wrapper | d-flex flex-column"><div class="text-muted text-uppercase mx-3 small">Advertisement</div><div id="ad-S4eGJ4EFF6H" class="wtoc/web/weather/forecast arcad"></div></div></div></section><div class="container-xl"><div class="row"><section class="top-wrapped | col-12"></section><div class="col-12 d-flex flex-column flex-lg-row w-100"><div class="article-content-container | flex-lg-fill mr-lg-3"><section class="header | w-100"><div class="article-header article row mb-3"><div class="headlines |"><h1 class="headline | font-weight-bold col"><span>Dave Turley’s Wednesday WX Forecast 6-23-3021</span></h1></div><div class="lead-art | col-12"><figure class="image | figure mb-0 constrained image-ratio-16x9"><div class="img-wrapper figure-img"><img class="img-fluid mx-auto d-block" alt="*" height="675" src="https://gray-wtoc-prod.cdn.arcpublishing.com/resizer/tfx9o81L5vz-GFj2_sl0ldA_qtI=/1200x675/smart/filters:format(jpg):quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/KZQOD2BCBNCYDOGZEHFFNFI56Y.png" width="1200"/></div><figcaption class="figure-caption">*<span class="ml-2">(wtoc)</span></figcaption></figure></div><div class="byline | col-12"><div class="authors |"><span class="">By </span><span class="author |"><a class="text-decoration-none" href="/authors/dave-turley/">Dave Turley</a></span><span></span></div></div><div class="date-time | col-12"><span class="date-time published-date-time font-italic d-inline-block">Published: <!-- -->Jun. 23, 2021 at 11:00 AM EDT</span><span class="px-2 d-inline">|</span><span class="date-time updated-date-time font-italic d-inline-block">Updated: <!-- -->48 minutes ago</span></div><div class="sharebar |  col-12"><div class="btn p-0 facebook"><svg class="icon |  facebook pointer" width="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Share on Facebook</title><path d="M12 2C6.477 2 2 6.477 2 12c0 4.991 3.657 9.128 8.438 9.878v-6.987h-2.54V12h2.54V9.797c0-2.506 1.492-3.89 3.777-3.89 1.094 0 2.238.195 2.238.195v2.46h-1.26c-1.243 0-1.63.771-1.63 1.562V12h2.773l-.443 2.89h-2.33v6.988C18.343 21.128 22 16.991 22 12c0-5.523-4.477-10-10-10" fill-rule="evenodd"></path></svg></div><div class="btn p-0 mail"><svg class="icon | mail pointer" width="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Email This Link</title><path d="M3.313 5.273C3.493 5.103 3.734 5 4 5h16c.13 0 .253.025.366.07L11.79 12.49 3.313 5.273zM21 7.166V18a1 1 0 0 1-1 1H4a1 1 0 0 1-1-1V7.775l8.064 6.867c.376.32.945.305 1.338-.036L21 7.166z" fill-rule="nonzero"></path></svg></div><div class="btn p-0 twitter"><svg class="icon | twitter pointer" width="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Share on Twitter</title><path d="M8.29 20.251c7.547 0 11.675-6.253 11.675-11.675 0-.178 0-.355-.012-.53A8.35 8.35 0 0 0 22 5.92a8.189 8.189 0 0 1-2.357.646 4.117 4.117 0 0 0 1.804-2.27 8.222 8.222 0 0 1-2.605.996 4.107 4.107 0 0 0-6.993 3.743 11.65 11.65 0 0 1-8.457-4.287 4.106 4.106 0 0 0 1.27 5.477A4.073 4.073 0 0 1 2.8 9.713v.052a4.105 4.105 0 0 0 3.292 4.022 4.095 4.095 0 0 1-1.853.07 4.108 4.108 0 0 0 3.834 2.85A8.233 8.233 0 0 1 2 18.407a11.617 11.617 0 0 0 6.29 1.84" fill-rule="evenodd"></path></svg></div><div class="btn p-0 pinterest"><svg class="icon | pinterest pointer" width="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Share on Pinterest</title><path d="M12 2C6.477 2 2 6.477 2 12c0 4.239 2.634 7.86 6.354 9.317-.09-.79-.165-2.008.033-2.873.18-.781 1.169-4.97 1.169-4.97s-.297-.602-.297-1.482c0-1.391.807-2.428 1.811-2.428.856 0 1.267.642 1.267 1.407 0 .856-.543 2.14-.83 3.334-.24.995.501 1.81 1.48 1.81 1.778 0 3.145-1.876 3.145-4.576 0-2.395-1.72-4.066-4.181-4.066-2.848 0-4.519 2.132-4.519 4.338 0 .856.33 1.777.74 2.28.083.098.091.189.067.288-.074.312-.247.995-.28 1.135-.041.181-.148.223-.338.132-1.25-.584-2.033-2.403-2.033-3.876 0-3.153 2.289-6.05 6.61-6.05 3.465 0 6.164 2.47 6.164 5.778 0 3.449-2.173 6.222-5.185 6.222-1.012 0-1.967-.527-2.288-1.152l-.626 2.379c-.222.872-.83 1.958-1.242 2.625.938.288 1.926.444 2.963.444 5.522 0 10-4.477 10-10A9.98 9.98 0 0 0 12 2" fill-rule="evenodd"></path></svg></div><div class="btn p-0 linkedin"><svg class="icon | linkedin pointer" width="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Share on LinkedIn</title><path d="M4.329 3H19.67C20.405 3 21 3.595 21 4.329V19.67c0 .734-.595 1.329-1.329 1.329H4.33A1.329 1.329 0 0 1 3 19.67V4.329C3 3.595 3.595 3 4.329 3zM18.35 17.901v-5.316c0-2.626-1.632-3.522-3.142-3.522-1.396 0-2.31.904-2.572 1.433h-.035V9.305H10V17.9h2.706v-4.66c0-1.243.787-1.847 1.59-1.847.76 0 1.349.427 1.349 1.812v4.695h2.706zM7.56 8.107c.86 0 1.56-.656 1.56-1.553C9.12 5.656 8.42 5 7.56 5 6.697 5 6 5.656 6 6.554c0 .897.698 1.553 1.56 1.553zm-1.354 9.788h2.706V9.298H6.207v8.597z" fill-rule="evenodd"></path></svg></div></div></div></section><section class="body | w-100"><div class="article-body | article w-100"><p class="text | article-text">SAVANNAH, Ga. (WTOC) -A cold front will stall just south of the area tonight&nbsp;through Thursday. &nbsp;This will keep us cooler, less humid and with only a slight chance for mainly afternoon/evening showers and storms. &nbsp;High pressure settles to our north through Friday. &nbsp;The circulation around the high will keep our temps well below average due an onshore flow. &nbsp;Rain chances decrease slightly this weekend allowing for more sun and warmer temps.</p><p class="text | article-text">Today will be partly cloudy with a 20% chance for showers and storms, highs 85-89.</p><p class="text | article-text">Tonight will be partly cloudy with a 10% chance for showers and storms early, lows 69-77.</p><p class="text | article-text">Thursday will be partly to mostly cloudy with a 30% chance for showers and storms, highs in the mid 80s.</p><div></div><p class="text | article-text">Thursday night&nbsp;will be mostly cloudy with a 20% chance for showers, lows in the upper 60s.</p><p class="text | article-text">Friday will be partly to mostly cloudy with a 30% chance for showers and storms, highs in the mid 80s.</p><p class="text | article-text">Friday night&nbsp;will be mostly cloudy with a 20% chance for showers, lows near 70.</p><p class="text | article-text">Saturday will be partly to mostly cloudy with a 30% chance for showers and storms, highs in the mid 80s.</p><div></div><p class="text | article-text">Saturday night&nbsp;will be partly cloudy with a 10% chance for showers, lows in the low 70s.</p><p class="text | article-text">Sunday will be partly to mostly cloudy with a 30% chance for showers, highs in the upper 80s.</p><p class="text | article-text">Sunday night&nbsp;will be partly cloudy with a 10% chance for showers, lows in the low 70s.</p><p class="text | article-text">Monday will be partly cloudy with a 30% chance for showers and storms, highs near 90.</p><div></div><p class="text | article-text">Monday night will be partly cloudy with a 10% chance for showers early, lows in the low 70s.</p><p class="text | article-text">Tuesday will be partly cloudy with a 30% chance for showers and storms, highs near 90.</p><p class="text | article-text">Tuesday night will be mostly clear, with a 10% chance for showers, lows in the low 70s</p><p class="text | article-text">TROPICS: &nbsp;A tropical wave located a few hundred miles east of the Windward Islands has remains very disorganized. &nbsp;There is only a 10% chance for tropical development in the next 2 days. &nbsp;The wave will continue moving to the west-northwest where it is encountering strong upper level winds. &nbsp;This should help keep the system weak.</p><div></div><p class="text | article-text"><i>Copyright 2021 WTOC. All rights reserved.</i></p></div></section><section class="recommendations | w-100"><div id="fusion-static-enter:b7db01a4-7549-4cd5-b57a-752c49101464" style="display:none" data-fusion-component="b7db01a4-7549-4cd5-b57a-752c49101464"></div><div class="connatix | row mb-3"><div class="my-3 col"><div id="connatix-highlights-embed" class="w-100 h-100"><script id="a8e266bfac5841009afeb5359bf68301">
            cnxps.cmd.push(function() {
              cnxps({
              playerId: "b7db01a4-7549-4cd5-b57a-752c49101464",
            }).render("a8e266bfac5841009afeb5359bf68301");
          });</script></div></div></div><div id="fusion-static-exit:b7db01a4-7549-4cd5-b57a-752c49101464" style="display:none" data-fusion-component="b7db01a4-7549-4cd5-b57a-752c49101464"></div></section></div><section class="right-rail | rail ml-lg-3 d-flex flex-column flex-lg-fill"><div></div><div class="flex-feature-feed | mb-0"><div class="title-bar | w-100"><h4 class="title | font-weight-bold"><span class="">Most Read</span></h4></div><div class="card-deck mx-n2 mb-0"><div class="flex-feature | card mx-2 mb-3 align-items-start border image-right position-relative w-100"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-right ml-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/2021/06/22/pooler-police-looking-suspect-after-shooting-near-towne-center-boulevard/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="Pooler Police on the scene of a shooting near Towne Center Boulevard." height="450" src="https://gray-wtoc-prod.cdn.arcpublishing.com/resizer/88joMWSiccTK9m7TI0JDGO5IoF8=/800x450/smart/filters:format(jpg):quality(70)/cloudfront-us-east-1.images.arcpublishing.com/gray/6F3PIBFGCZCJLP573SQ5WHECDE.jpg" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/2021/06/22/pooler-police-looking-suspect-after-shooting-near-towne-center-boulevard/" rel="" target="_self"><span><i class="far fa-play-circle"></i><span style="textDecoration: none;"> </span>Pooler Police looking for suspect after shooting near Towne Center Boulevard</span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div><div class="flex-feature | card mx-2 mb-3 align-items-start border image-right position-relative w-100"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-right ml-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/2021/06/22/mother-warns-parents-after-child-bitten-by-venomous-snake/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="Maisy Lamica was bit by a timber rattlesnake in Berrien County, she is currently being treated." height="450" src="https://gray-wtoc-prod.cdn.arcpublishing.com/resizer/IDQu-2cV7GXWjy1O4Fd3f0S2nzM=/800x450/smart/filters:format(jpg):quality(70)/cloudfront-us-east-1.images.arcpublishing.com/gray/AFQ4GHHHGRBX3I3XXS6NKP5WFM.png" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/2021/06/22/mother-warns-parents-after-child-bitten-by-venomous-snake/" rel="" target="_self"><span><i class="far fa-play-circle"></i><span style="textDecoration: none;"> </span>Mother warns parents after child bitten by venomous snake</span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div><div class="flex-feature | card mx-2 mb-3 align-items-start border image-right position-relative w-100"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-right ml-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/2021/06/22/5-year-old-fighting-life-after-rattlesnake-bites-her-several-times/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="Maisy Lamica was bit by a timber rattlesnake in Berrien County, she is currently being treated." height="450" src="https://gray-wtoc-prod.cdn.arcpublishing.com/resizer/IDQu-2cV7GXWjy1O4Fd3f0S2nzM=/800x450/smart/filters:format(jpg):quality(70)/cloudfront-us-east-1.images.arcpublishing.com/gray/AFQ4GHHHGRBX3I3XXS6NKP5WFM.png" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/2021/06/22/5-year-old-fighting-life-after-rattlesnake-bites-her-several-times/" rel="" target="_self"><span><i class="far fa-play-circle"></i><span style="textDecoration: none;"> </span>5-year-old fighting for life after rattlesnake bites her several times</span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div><div class="flex-feature | card mx-2 mb-3 align-items-start border image-right position-relative w-100"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-right ml-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/2021/06/22/savannah-mayor-announces-end-parklet-program/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="As we slowly get back to normal, a pandemic-era program is ending in Savannah. Mayor Van..." height="450" src="https://gray-wtoc-prod.cdn.arcpublishing.com/resizer/J48GlJXPx0dhg9hK3E3BiS6B5i8=/800x450/smart/filters:format(jpg):quality(70)/cloudfront-us-east-1.images.arcpublishing.com/gray/RAJYQ2XAOZEVJCDKSER4JDZ5UQ.jpg" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/2021/06/22/savannah-mayor-announces-end-parklet-program/" rel="" target="_self"><span><i class="far fa-play-circle"></i><span style="textDecoration: none;"> </span>Savannah mayor announces end to parklet program</span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div><div class="flex-feature | card mx-2 mb-3 align-items-start border image-right position-relative w-100"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-right ml-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/2021/06/22/dad-witnesses-crash-that-kills-two-daughters-fathers-day/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="Kaele and Sara Polzin were killed in a traffic accident." height="450" src="https://gray-wtoc-prod.cdn.arcpublishing.com/resizer/-Ix6eVcRTrNyrs_XKD25YCN5DM4=/800x450/smart/filters:format(jpg):quality(70)/cloudfront-us-east-1.images.arcpublishing.com/gray/E42YK467U5DZFP7IH4JAJUJTUY.jpg" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/2021/06/22/dad-witnesses-crash-that-kills-two-daughters-fathers-day/" rel="" target="_self"><span>Dad witnesses crash that kills two daughters on Father’s Day</span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div></div></div><div class="lazy-load"></div><div></div><div class="flex-feature-feed | mb-0"><div class="title-bar | w-100"><h4 class="title | font-weight-bold"><span class="">Latest News</span></h4></div><div class="card-deck mx-n2 mb-0"><div class="flex-feature | card mx-2 mb-3 align-items-start border image-left position-relative w-100 is-video"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-left mr-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/video/2021/06/23/video-drier-day-with-warm-afternoon-temperatures/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="Dry at 5:21 a.m." height="450" src="https://gray-wtoc-prod.cdn.arcpublishing.com/resizer/Pa68V7OJSKRPC622MJvHqweQt4I=/800x450/smart/filters:format(jpg):quality(70)/do0bihdskp9dy.cloudfront.net/06-23-2021/t_ebd320d847134e8192612deeff5842f7_name_file_1280x720_2000_v3_1_.jpg" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/video/2021/06/23/video-drier-day-with-warm-afternoon-temperatures/" rel="" target="_self"><span>VIDEO | A drier day with warm afternoon temperatures</span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div><div class="flex-feature | card mx-2 mb-3 align-items-start border image-left position-relative w-100"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-left mr-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/2021/06/23/wednesday-warmer-temperatures-spotty-rain-are-forecast/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="First Alert Weather" height="450" src="https://gray-wtoc-prod.cdn.arcpublishing.com/resizer/2ovlngwtOssDYasLdghFtm4JsPo=/800x450/smart/filters:format(jpg):quality(70)/cloudfront-us-east-1.images.arcpublishing.com/gray/EUG4F3UGAVBNHIX53RO742FU5A.png" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/2021/06/23/wednesday-warmer-temperatures-spotty-rain-are-forecast/" rel="" target="_self"><span><i class="far fa-play-circle"></i><span style="textDecoration: none;"> </span>WEDNESDAY | Warmer temperatures, spotty rain are in the forecast!</span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div><div class="flex-feature | card mx-2 mb-3 align-items-start border image-left position-relative w-100"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-left mr-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/2021/06/22/dave-turleys-tuesday-wx-forecast-6-22-2021/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="*" height="450" src="https://gray-wtoc-prod.cdn.arcpublishing.com/resizer/dhjP5atHevHMheCbiMUkYLn29do=/800x450/smart/filters:format(jpg):quality(70)/cloudfront-us-east-1.images.arcpublishing.com/gray/KZQOD2BCBNCYDOGZEHFFNFI56Y.png" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/2021/06/22/dave-turleys-tuesday-wx-forecast-6-22-2021/" rel="" target="_self"><span>Dave Turley’s Tuesday WX Forecast 6-22-2021</span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div><div class="flex-feature | card mx-2 mb-3 align-items-start border image-left position-relative w-100 is-video"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-left mr-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/video/2021/06/22/video-wet-tuesday-is-forecast/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="Tracking spotty rain at 6:23 a.m." height="450" src="https://gray-wtoc-prod.cdn.arcpublishing.com/resizer/2yOKC1TiqXHdkstIzHfbFFPxF9I=/800x450/smart/filters:format(jpg):quality(70)/do0bihdskp9dy.cloudfront.net/06-22-2021/t_e4677f47e5454eadae2c8d34744f70af_name_file_1280x720_2000_v3_1_.jpg" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/video/2021/06/22/video-wet-tuesday-is-forecast/" rel="" target="_self"><span>VIDEO | Wet Tuesday is in the forecast</span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div></div></div><div></div></section></div><section class="bottom-wrapped | col-12"><div></div></section></div></div><footer class="footer | w-100"><div class="arc-ad | text-center ad-flex-leaderboard ad-flex-footer-leaderboard ad-fixed-bottom position-fixed zindex-higher w-100 py-0 my-0 d-flex flex-column justify-content-center ad-type-flex-leaderboard"><div class="arc-ad-wrapper | d-flex flex-column"><div class="ad-dismiss | text-white pointer position-absolute top absolute-right p-1"><i class="far fa-times-circle fa-sm"></i></div><div id="ad-0-Bb4nXEu8Y" class="wtoc/web/weather/forecast arcad"></div></div></div><div id="fusion-static-enter:footer-wtoc" style="display:none" data-fusion-component="footer-wtoc"></div><div class="footer | card bg-primary-branding mt-3 d-flex rounded-0 text-center text-sm-left zindex-highest"><div class="card-body"><div class="container"><div class="row"><div class="col"><div class="footer-links | row justify-content-start my-3"><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/news" rel="" target="_self">News</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/weather" rel="" target="_self">First Alert Weather</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/sports" rel="" target="_self">Sports</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/news/investigate" rel="" target="_self">WTOC Investigates</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/community" rel="" target="_self">Community</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/livestream/" rel="" target="_self">Watch Live</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/programming/schedule" rel="" target="_self">Programming Schedule</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/about-us/contact-us" rel="" target="_self">Contact Us</a></div></div></div><div class="col-12 col-sm-5 col-md-3 col-xl-2"><div class="footer-contacts | row justify-content-start my-3 small"><div class="col"><ul class="list-unstyled mb-0"><li class="footer-contact | font-weight-bold">WTOC</li><li class="footer-contact | footer-address">P.O. Box 8086</li><li class="footer-contact | footer-city-state">Savannah, GA 31412</li><li class="footer-contact | footer-phone">(912) 234-1111</li></ul></div></div></div></div></div></div><div class="card-footer small pt-0"><div class="footer-links | d-flex flex-wrap justify-content-center text-center"><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="http://publicfiles.fcc.gov/tv-profile/wtoc-tv" rel="noopener norefferer" target="_blank">FCC Public File</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="mailto:publicfile@wtoc.com" rel="noopener norefferer" target="_blank">publicfile@wtoc.com - (912) 234-1111</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://webpubcontent.gray.tv/gdm/fcc/wtoc-fcc_applications.pdf" rel="noopener norefferer" target="_blank">FCC Applications</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://drive.google.com/file/d/1LvBlRrwxutZGkAI07Wr80uqBo63wxGoI/view?usp=sharing" rel="noopener norefferer" target="_blank">EEO Report</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/story/35154723/about-wtoc/" rel="noopener norefferer" target="_blank">Closed Captioning</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://gray.tv/careers#currentopenings" rel="noopener norefferer" target="_blank">WTOC Careers</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/terms-of-service" rel="noopener norefferer" target="_blank">Terms of Service</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/privacy-policy" rel="noopener norefferer" target="_blank">Privacy Policy</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/advertising" rel="noopener norefferer" target="_blank">Advertising</a></div><div id="ccpa-link" class="ccpa-dynamic-insertion-container d-flex align-self-center"></div></div></div><div class="footer-copyright | card-footer"><div class="font-weight-light small mx-auto text-center">A Gray Media Group, Inc. Station - <!-- -->© <!-- --> <!-- -->2002-2021 Gray Television, Inc.</div><div class="footer-corp-logo | w-100 mx-auto mt-2 mb-0"></div></div></div><div id="fusion-static-exit:footer-wtoc" style="display:none" data-fusion-component="footer-wtoc"></div></footer></div></div><script id="fusion-metadata" type="application/javascript">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</script></body></html>